Details
-
Type: Improvement
-
Status: Closed
-
Priority: Major
-
Resolution: Fixed
-
Affects Version/s: 1.0-RC-1
-
Fix Version/s: 1.0-RC-1
-
Component/s: PicoContainer (Java)
-
Labels:None
-
Number of attachments :
Description
InterfaceFinder is a classic utility class without any state. It is not necessary to have instances of the class.
Proposal:
- Add a private standard ctor
- Make all methods static
- Remove unnecessary Serializable
Cons:
- avoids unnecessary object creation
- avoids unnecessary object members (e.g. in IHCA)
- avoids unnecessary serialization (e.g. in IHCA)
Aslak, please assign me, if I shall do this.
Activity
Aslak Hellesøy
made changes -
Field | Original Value | New Value |
---|---|---|
Assignee | Joerg Schaible [ joehni ] |
Jörg Schaible
made changes -
Resolution | Fixed [ 1 ] | |
Status | Open [ 1 ] | Closed [ 6 ] |
I'm all for making this a class with only static methods. Also, since the class now deals with classes too, I think it should be renamed ClassHierarchyIntrospector or something.
The testMostCommonSuperclassForJComponents runs really slowly. It would be great if you could optimise the getClass method.
Finally, I disagree with the usage of Void.class. Void is not a superclass for anything, and IMO, Object should be used instead.